Log in Register FAQ Memberlist Search pcHDTV Forum Index
pcHDTV Forum

pcHDTV Forum Index -> xine-hd -> on amd64 - no XvMC (Xvideo *static*) - compiling fails
Post new topic  This topic is locked: you cannot edit posts or make replies. View previous topic :: View next topic 
on amd64 - no XvMC (Xvideo *static*) - compiling fails
PostPosted: Sat May 13, 2006 11:42 am Reply with quote
Joined: 06 May 2006
Posts: 14

I am testing a intended mythtv box on Comcast HDTV (as mentioned in a post under General pcHDTV topics). Here, I wanted to explain my difficulties with xine-hd-lib and suggest how pchdtv programmers might quickly devise a solution.
I have a 3000 card (along with an nvidia agp card) on a 2.6.12 kernel amd64 machine (Debian Etch). I have a lot of experience on this platform and it has worked splendidly for all of my other applications, services, etc.

I have not yet looked at xine-hd itself; it may or may not work fine.
xine-hd-lib has both configuring (or perhaps documentation?) and compiling problems.

(1) xine-hd-lib can't find "XvMC (Xvideo *static*)" which the README demands. I did,
./configure -with-xv-path=/usr/X11R6/lib/
which, at the end showed,
"* video driver plugins:" shows "- Xv (XVideo *static*)"
libxvmc is indeed installed, and even when I specify the path for it thus (as a one line command),
./configure -with-xv-path=/usr/X11R6/lib/ --with-xvmc-path=/usr/X11R6/lib/
I fail to see "XvMC (Xvideo *static*)" which the README demands!
How can this be? How can I make xine-lib find the "XvMC (Xvideo *static*)"? On Debian Etch I saw an additional file appear in /usr/X11R6/lib/ after I installed the libxvmc package, but could the xvmc be elsewhere?
(2) xine-hd-lib won't compile on amd64. make chokes here,
(I have to omit the beginning gcc command because the webserver forbids me from posting them -- no kidding!)
-fomit-frame-pointer -fexpensive-optimizations -fschedule-insns2 -fno-strict-aliasing -ffast-math -funroll-loops -finline-functions -Wall -DNDEBUG -D_REENTRANT -D_FILE_OFFSET_BITS=64 -DXINE_COMPILE -Wpointer-arith -Wnested-externs -Wcast-align -Wchar-subscripts -Wmissing-declarations -Wmissing-prototypes -c color.c -MT color.lo -MD -MP -MF .deps/color.TPlo -fPIC -DPIC -o .libs/color.o
color.c: In function 'vscale_chroma_line':
color.c:498: error: invalid lvalue in increment
color.c:499: error: invalid lvalue in increment

Apparently, this is a known problem for xine-hd-lib and amd64. A patch is here
in the middle of the page, and it does address the color.c problem. Unfortunately, make still chokes before completion.
Could one of your programmers please blend your patch with the patch from the above website to make a patched xine-hd-lib that works on amd64?

Does anyone know of an existing work-around for this problem?
View user's profile Send private message
PostPosted: Sat May 13, 2006 4:45 pm Reply with quote
Joined: 06 May 2006
Posts: 14

First, I must say, I appreciate the continuing helpful advice.
That said, I wanted to share some progress and ask for further help.

As I partly explained in a (the?) preceding post,
I am working on Debian Etch 2.6.12 amd64

I managed some progress thus

(1) I installed libxvmc: dpkg -i libxvmc1_6.8.2.dfsg.1-7_amd64.deb

(2) To allow recognition of XvMC (Xvideo *static*), I tried what one poster did.
I edited the Device section of
Option "RenderAccel" "1"
and I restarted X.

(3) From the CD that came with the card, I got FedoraCore2-HD3000-driver-rev-1.4.tar.gz
and did
tar -zxf FedoraCore2-HD3000-driver-rev-1.4.tar.gz
cd FedoraCore2-HD3000-driver-rev-1.4
install -c include/videodev.h /usr/include/linux
to give me the "new" videodev.h
which allowed me to compile xine-hd-lib.

(4) I compiled and installed xine-hd-lib thus
./configure CC=/usr/bin/gcc-3.4 --with-xv-path=/usr/X11R6/lib/ --with-xvmc-path=/usr/X11R6/lib/
still gave "Xv (XVideo *static*)" but not XvMC!
make install
Despite step #2, configure still just gave me
"* video driver plugins:" shows "- Xv (XVideo *static*)"
how can I get the legendary "XvMC (Xvideo *static*)" which the README demands?

(5) I had to use gcc-3.4 for compiling xine-hd, which I did thus.
export LD_LIBRARY_PATH="/usr/local/lib"
./configure CC=/usr/bin/gcc-3.4
make install

Progress: I now have an apparently working xine-hd (although, it appears to lack "XvMC (Xvideo *static*)" which the README implies is mandatory).

(6) As described in this post
(copied verbatim)
I did ./atscscan atsc/us-Cable-Standard-center-frequencies-QAM256 > channels.conf
I did not see any difference between using the > vs the >> here.
The output was 312 channels. (My first attempt gave me 279 channels.)
I then put a copy of channels.conf in the appropriate .azap and .mplayer directories. Isn't there something strange about its contents (which follow)?
Note how they differ from those in your first weblink in that the first entry of each line lacks a hyphen (e.g. not [001-0001]). Why don't I have that hyphenated format?
Also, why do channels (like [0001]) repeat several times?

(7) I copied this channels.conf into ~/.xine
but when I run xine and click on dvb, xine says
There is no input plugin available to handle
Why not? I created channels.conf just as I was told to do?
What the heck is wrong with my channels.conf?
View user's profile Send private message
on amd64 - no XvMC (Xvideo *static*) - compiling fails
  pcHDTV Forum Index -> xine-hd
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum
All times are GMT - 7 Hours  
Page 1 of 1  

 Post new topic  This topic is locked: you cannot edit posts or make replies.  

Powered by phpBB © 2001-2003 phpBB Group
Theme created by Vjacheslav Trushkin