Log in Register FAQ Memberlist Search pcHDTV Forum Index
pcHDTV Forum

pcHDTV Forum Index -> HD-2000/3000 drivers -> 1.6 driver installes, no device created
Post new topic  This topic is locked: you cannot edit posts or make replies. View previous topic :: View next topic 
1.6 driver installes, no device created
PostPosted: Mon Mar 21, 2005 10:19 am Reply with quote
Robert
 
Joined: 20 Mar 2005
Posts: 9
Location: Bainbridge Island, WA




I installed the 1.6 drivers into a 2.6.8.1 kernel and rebooted. The card is recognized and the modules load, but if I try to run one of the tool commands, it is looking for a /dev/dtv device. There are no dtv devices in /dev, although DMESG reports "registered device dtv0":

cx2388x v4l2 driver version 0.0.4 loaded
pcHDTV HD3000 Driver Version 1.6
PCI: Found IRQ 9 for device 0000:00:0c.0
PCI: Sharing IRQ 9 with 0000:00:0c.2
cx8800[0]: found at 0000:00:0c.0, rev: 5, irq: 9, latency: 32, mmio:
0xe3000000
cx8800[0]: subsystem: 7063:3000, board: pcHDTV HD3000 HDTV
[card=14,autodetected]
cx8800[0]: i2c register ok
tuner: chip found at addr 0xc2 i2c-bus cx8800[0]
tuner: type set to 51 (Thomson DDT 7610 ATSC/NTSC)) by cx8800[0]
cx8800[0]: i2c attach [client=Thomson DDT 7610 ATSC/NTSC)]
cx8800[0]: registered device video0 [v4l2]
cx8800[0]: registered device vbi0
cx88: registered device dtv0
cx8800[0]: pcHDTV_HD3000 calling init_dvr
PCI: Found IRQ 9 for device 0000:00:0c.2
PCI: Sharing IRQ 9 with 0000:00:0c.0
cx88:: 0 Version Data: 10001134-19430000
cx88:: 1 Version Data: 10001134-19430000
cx88:: Version: 113-4-194-3

How do I create this device? MAKEDEV says "don't know how to make device dtv0"

If I use video0 or vbi0 I get a response but the tools-2.6-a README says to use a dtv device.
View user's profile Send private message
PostPosted: Tue Mar 22, 2005 10:07 am Reply with quote
Robert
 
Joined: 20 Mar 2005
Posts: 9
Location: Bainbridge Island, WA




OK, running minstall from tools-2.6a created the device. Now to see if I can get it to return after a reboot (udev can make things interesting).
View user's profile Send private message
PostPosted: Tue Mar 22, 2005 10:12 pm Reply with quote
pcHDTV_tech
 
Joined: 16 Dec 2004
Posts: 295




If you are using udev then down load the version 2.0 drivers (you don't need to install them) and grab the files from the udev directory. Put the .rules file into /etc/udev/rules.d and the .permissions file into /etc/udev/permissions.d You should then get a symbolic link of /dev/dtv to the DTV interface to the card when you load the drivers.

Rusty
View user's profile Send private message Visit poster's website
PostPosted: Wed Mar 23, 2005 9:07 pm Reply with quote
Robert
 
Joined: 20 Mar 2005
Posts: 9
Location: Bainbridge Island, WA




pcHDTV_tech wrote:
If you are using udev then down load the version 2.0 drivers (you don't need to install them) and grab the files from the udev directory. Put the .rules file into /etc/udev/rules.d and the .permissions file into /etc/udev/permissions.d You should then get a symbolic link of /dev/dtv to the DTV interface to the card when you load the drivers.

Rusty


I tried it and it actually created /dev/dtv, dev/dtv0, dev/dtv1, dev/dtv2 and /dev/dtv3 devices, not symbolic links, but no matter, it works.

The picture is a bit jerky and on one channel I don't get any sound, but it's a start.
View user's profile Send private message
1.6 driver installes, no device created
  pcHDTV Forum Index -> HD-2000/3000 drivers
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum
All times are GMT - 7 Hours  
Page 1 of 1  

  
  
 Post new topic  This topic is locked: you cannot edit posts or make replies.  


Powered by phpBB © 2001-2003 phpBB Group
Theme created by Vjacheslav Trushkin